docker nginx配置写错,启动不了容器的解决方案

新建了一个docker容器,修改了nginx的配置文件时候,少了一个分号,nginx配置错误,导致nginx容器启动不了。因为容器没有启动,所以不能进入容器里面改。查看报错的docker容器的方式:docker logs 容器名解决方案如下:1.首先把容器里面的配置复制出来```shell docker cp mynginx:/etc/nginx/conf.d/...
阅读全文

docker搭建lnmp环境

系统环境:配好网络的虚拟机 CentOS 7Docker的安装和启动命令```shellwget qO https://get.docker.com | sh 安装dockersudo usermod aG docker king 指定用户可操作dockersudo service docker restart 重启docker```一、docker安装mysq...
阅读全文

thinkphp “未定义数组索引” 错误

thinkphp5.1报错提示未定义数组索引可以在app.php配置文件中加入关闭错误提示的语句```phperror_reporting(E_ERROR | E_WARNING | E_PARSE);```
阅读全文

翻墙后git出现 Failed to connect to 127.0.0.1 port xxxx: Connection refused

某天,用git拉取,提交代码的时候出现了git Failed to connect to 127.0.0.1 port xxxx: Connection refused的问题,如果翻墙的话可能会出现这个问题,开始百度,看了一通。都是如下路数,在git bash中:方式一首先,查一下代理:git config global http.proxy有没有呢,有就取消git config ...
阅读全文

tar 命令详解

在Linux中,压缩与解压用得最多的tar.tar命令确实很厉害。tar c: 建立压缩档案x:解压t:查看内容r:向压缩归档文件末尾追加文件u:更新原压缩包中的文件以上五个是独立的命令参数,压缩解压都要用到其中一个,可以和别的命令连用但只能用其中一个。下面的参数是根据需要在压缩或解压档案时可选的。z:有gzip属性的 gzj:有bz2属性的 ...
阅读全文

php远程连接sqlserver数据库

服务器环境:centos7 + nginx + php7.2官方配置链接:https://docs.microsoft.com/zhcn/sql/connect/php/installationtutoriallinuxmac?view=sqlserver2017installingthedriverswithphpfpmonubuntu以下步骤是在已经安装了lnmp环境下的服...
阅读全文

nginx服务器设置防盗链,并解决app图片文件不显示问题,配置中转服务器

nginx配置防盗链在server块中加入以下配置```shelllocation .\.(gif|jpg|jpeg|png|bmp|swf|pdf|doc|docx|pptx|ppt|xls|xlsx)$ { root /www; valid_referers a.cn .b.cn 192.168.1.110; if ($invalid_refer...
阅读全文

Linux系统木马查杀

背景信息系统安全存在漏洞或未采取足够的安全加固措施时,Linux系统可能会被植入木马程序。及时清理木马程序后,还需提高安全意识,从安全补丁加固、系统权限加固、操作审计、日志分析等多维度对系统安全进行全方位提升。 步骤一:使用云安全中心查杀木马程序使用云安全中心安全告警处理,及时清理木马威胁。详细内容请参见查看和处理告警事件。及时修复系统漏洞,加固系统安全。详细内容请参见Lin...
阅读全文

thinkphp5.1表单内有多个单文件时报错 SplFileObject::__construct(/tmp/php1Xk2Qu): failed to open stream: No such file or directory

找到源文件thinkphp\library\think\File.php 在构造函数内加个判断if(file_exists($filename))```php public function __construct($filename, $mode = 'r') { if(file_exists($filename)){ ...
阅读全文

CentOS 7升级php5.4到php7.2

原因:CentOS 7下yum安装PHP版本默认是5.4的,但新框架要求PHP版本在7以上,所以把PHP升级一下了。 查看yum的可安装的php版本列表:```shellyum provides php``` 开始升级PHP更新源:```shellrpm Uvh https://mirror.webtatic.com/yum/el7/ep...
阅读全文